Re: [mu TECH] 'counter' a scripting util... / fitting names

From: Alfie Costa (
Date: Wed Sep 20 2000 - 21:56:46 CEST

On 20 Sep 2000, at 10:41, Michele Andreoli <> wrote:

> 'range' is the better solution; you can find this keyword also in some
> mathematical-oriented language.

I think 'range' may be a better name at that, and custom is a help. Another
fault of the name 'counter' is that most real life counters are things like
VCR tape counters, where there's one space, which changes the numbers in it
over time.

On the other hand, I think most mathematical language (in English at least) is
just deadly. And I like math... it's like a beautiful girl with an
unpronouncable name. So when it is advised, to call it thus for the reason the
math guys already do, it makes me a bit nervous!

So, a little progress, but maybe there is some other unused name out there that
is better still? Series, sequence, queue, vlad, (the impaler, after 'Count'
Dracula), order, step, trot, xeno, (after the Greek Philosopher)... of those
'queue' is nice, and has all the right connotations, but is difficult to spell;
'step' is OK, but only for numbers; and 'vlad' is easy to remember for all fans
of Bela Lugosi.

        # vlad 5
        1 2 3 4 5

What other distro of Linux would have that?

'range' is alright though, I shall be content to defer to Michele. And a
question for Python users: what's the syntax of Python's 'range' statement?

To unsubscribe, e-mail:
For additional commands, e-mail:

This archive was generated by hypermail 2.1.6 : Sat Feb 08 2003 - 15:27:16 CET