Re: [mu TECH] 'counter' a scripting util... / fitting names

Date: Thu Sep 21 2000 - 15:52:39 CEST

In a message dated 9/20/00 8:29:50 PM Central Daylight Time,

> > 'range' is the better solution; you can find this keyword also in some
> > mathematical-oriented language.
> I think 'range' may be a better name at that, and custom is a help.
> fault of the name 'counter' is that most real life counters are things
> VCR tape counters, where there's one space, which changes the numbers in
> over time.
> On the other hand, I think most mathematical language (in English at
> is just deadly. And I like math... it's like a beautiful girl with an
> unpronouncable name. So when it is advised, to call it thus for the
> the math guys already do, it makes me a bit nervous!
> So, a little progress, but maybe there is some other unused name out there
> that is better still? Series, sequence, queue, vlad, (the impaler, after
> Dracula), order, step, trot, xeno, (after the Greek Philosopher)... of
> those 'queue' is nice, and has all the right connotations, but is difficult
> spell; 'step' is OK, but only for numbers; and 'vlad' is easy to remember
for all
> fans of Bela Lugosi.

To me, "range" has an implication of continuity (that is, there are no missing
values), which the script thing does not require (and is one of its
"Range" begs for conflicts of usage with the Python (and other) range

I'd prefer "list" or "que" or "chain"

To unsubscribe, e-mail:
For additional commands, e-mail:

This archive was generated by hypermail 2.1.6 : Sat Feb 08 2003 - 15:27:16 CET